Friendly Reminder! ITCO Solutions & Maxim Software Staff Function Today from 2pm
Scheduled for 22/11/2024 at 1:00 AM – 4:00 AM
Affects
ITCO Maxim
Under maintenance from 1:00 AM to 4:00 AM
MaximMX
Under maintenance from 1:00 AM to 4:00 AM
Completed
22/11/2024 at 4:00 AMCompleted
22/11/2024 at 4:00 AMMaintenance has completed successfully
In progress
22/11/2024 at 1:00 AMIn progress
22/11/2024 at 1:00 AMMaintenance is now in progress
Planned
22/11/2024 at 1:00 AMPlanned
22/11/2024 at 1:00 AMOur Team will be out of office tomorrow (Friday) from 2pm for our staff
Christmas function.
We will be available if you require urgent assistance at this time.
Thank you for your understanding.