ITCO Systems - NOTIFICATION: Server Disruption ITCO ZoomCloud and ITCO MaximSoftware – Incident details

NOTIFICATION: Server Disruption ITCO ZoomCloud and ITCO MaximSoftware

Resolved
Operational
Started about 1 month agoLasted 42 minutes

Affected

ITCO ZoomCloud

Partial outage from 11:29 PM to 12:11 AM

ZoomCloud Desktop

Partial outage from 11:29 PM to 12:11 AM

ZoomCloud printing

Partial outage from 11:29 PM to 12:11 AM

ZoomCloud Email

Partial outage from 11:29 PM to 12:11 AM

ZoomCloud Apps

Partial outage from 11:29 PM to 12:11 AM

Hosted Servers

Partial outage from 11:29 PM to 12:11 AM

Updates
  • Resolved
    Resolved

    All systems are now Operational as per normal. Thanks for your patience.

    Please contact our team if you have any further issues.

  • Identified
    Identified

    Hello All,

    We are currently experiencing temporary disruption with our services. Our technical team is actively working to resolve this incident as soon as possible. 

    Date:                            Tuesday, 13th May 2025 
    Outage Start Time:       11:20 am
    Services Affected:         ITCO ZoomCloud (All Components)

    ITCO ZoomWorkspaces (All Components)
                                         ITCO Maxim Software (All Components)

    We will continue to update our inStatus Portal which will serve as the authoritative source of information on this incident. We will be delivery updates every 30 minutes or as new information becomes available.   

    We apologise for any inconvenience caused and thank you for your patience and understanding.     
                      
    Many thanks
    ITCO Support Team