ITCO Systems - Partial Internet Outage Notification – Incident details

Partial Internet Outage Notification

Resolved
Degraded performance
Started about 2 months agoLasted 42 minutes

Affected

ITCO ZoomWorkspaces

Degraded performance from 10:18 PM to 11:00 PM

Email, Teams, Files

Degraded performance from 10:18 PM to 11:00 PM

Updates
  • Resolved
    Resolved

    Internet connectivity has been fully restored, and all our services are now back to normal.

    Thank you for your patience.

    -ITCO Support

  • Update
    Update

    The issue affecting internet connectivity for our customers has been identified.

    An external service provider is currently working to resolve the problem.

    We will continue to monitor the situation and provide updates as they become available.

    Thank you for your patience and understanding.

    -ITCO Support.

  • Identified
    Identified
    We are currently experiencing a partial internet outage which is affecting connectivity for some users. Our Technical team is actively investigating the issue and working to restore full service as soon as possible. We appreciate your patience and will provide further updates as more information becomes available. Thank you for your understanding. \-ITCO Support