NOTIFICATION: ITCO Planned Maintenance
Scheduled for 13/11/2025 at 7:00 AM – 8:00 AM
Affects
ITCO ZoomCloud
Under maintenance from 7:00 AM to 8:00 AM
Hosted Servers
Under maintenance from 7:00 AM to 8:00 AM
ITCO Maxim
Under maintenance from 7:00 AM to 8:00 AM
Maxim Classic
Under maintenance from 7:00 AM to 8:00 AM
Maxim Mobile
Under maintenance from 7:00 AM to 8:00 AM
Maxim Reports
Under maintenance from 7:00 AM to 8:00 AM
Completed
13/11/2025 at 8:00 AMCompleted
13/11/2025 at 8:00 AMMaintenance has completed successfully
Planned
13/11/2025 at 7:00 AMPlanned
13/11/2025 at 7:00 AMSYSTEM MAINTENANCE
Hello All,
Please be advised our team are undertaking planned maintenance tonight for mandatory security patching
You may experience several 60-second disconnections during this time.
Outage Date: Day, 13th November 2025
Outage Time: 8 pm and 9 pm (
Databases affected: ITCO (All Customers)
Maxim Software (All Customers)
Services affected: All components:
ITCO ZoomWorkspaces,
ITCO ZoomCloud
ITCO Maxim,
ITCO Earlywatch,
Many Thanks
ITCO Server Team
In progress
13/11/2025 at 2:55 AMIn progress
13/11/2025 at 2:55 AMMaintenance is now in progress.