ITCO Systems - NOTIFICATION: Server Disruption โ€“ Incident details

System Under Maintenance

NOTIFICATION: Server Disruption

Resolved
Major outage
Started 18 days agoLasted 18 minutes

Affected

ITCO ZoomCloud

Major outage from 11:39 PM to 11:57 PM

ZoomCloud Desktop

Major outage from 11:39 PM to 11:57 PM

ZoomCloud printing

Major outage from 11:39 PM to 11:57 PM

ZoomCloud Email

Major outage from 11:39 PM to 11:57 PM

ZoomCloud Apps

Major outage from 11:39 PM to 11:57 PM

Hosted Servers

Major outage from 11:39 PM to 11:57 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We implemented a fix, all services operational, we are currently monitoring status.

  • Identified
    Identified

    Hello All,

    We are currently experiencing temporary disruption with our services. Our technical team is actively working to identify and resolve this incident as soon as possible. 

    Date:                            Friday, 8th May 2026 
    Outage Start Time:     11:30 am
    Services Affected:     (All Components)
                                         

    We will continue to update our inStatus Portal which will serve as the authoritative source of information on this incident.

    We will be delivery updates as new information becomes available.   

    We apologise for any inconvenience caused and thank you for your patience and understanding.     
                      
    Many thanks
    ITCO Server Team