ITCO Systems - Chorus Power Outage affecting most of Rotorua – Incident details

Chorus Power Outage affecting most of Rotorua

Resolved
Major outage
Started about 2 months agoLasted about 1 hour
Updates
  • Resolved
    Resolved

    Unison have confirmed that ALL power should now be restored to the entire Rotorua area. Should you experience issues with startup of devices or regaining connectivity, please contact our Helpdesk on 0800 323 484.

  • Monitoring
    Monitoring

    Most of Rotorua is back up and running. However, there are areas still out if they are on other feeds. Thanks again for your patience. We will update you once power fully restored.

  • Investigating
    Investigating

    Most of our team are currently unable to field calls. We have a skeleton crew able to take calls. We will keep you updated.

    Note that if you are outside the Rotorua area and using hosted servers or Microsoft 365 products, you should be able to continue to operate.

    Thank you for your patience!