ITCO Systems - Unplanned Outage - 16/06/2025 – Incident details

Unplanned Outage - 16/06/2025

Resolved
Degraded performance
Started about 19 hours agoLasted about 2 hours

Affected

ITCO ZoomCloud

Operational from 8:40 PM to 9:18 PM, Degraded performance from 9:18 PM to 10:40 PM

ZoomCloud Desktop

Operational from 8:40 PM to 9:18 PM, Degraded performance from 9:18 PM to 10:40 PM

ZoomCloud printing

Operational from 8:40 PM to 9:18 PM, Degraded performance from 9:18 PM to 10:40 PM

ZoomCloud Email

Operational from 8:40 PM to 9:18 PM, Degraded performance from 9:18 PM to 10:40 PM

ZoomCloud Apps

Operational from 8:40 PM to 9:18 PM, Degraded performance from 9:18 PM to 10:40 PM

Hosted Servers

Operational from 8:40 PM to 9:18 PM, Degraded performance from 9:18 PM to 10:40 PM

Updates
  • Resolved
    Resolved

    This incident has been resolved. Thank you for your patience.

  • Identified
    Identified

    We have identified the issue and are bringing back all users affected back online. Thank you for your patience.

  • Investigating
    Investigating

    We’re aware of a temporary service disruption that is affecting some customers. We are working to resolve it as quickly as possible. Thank you for your understanding. Another update to be provided in the next 20 minutes.