ITCO Systems - Information of Outage with Starlink - Not related to ZoomCloud Services, Informational only – Incident details

Information of Outage with Starlink - Not related to ZoomCloud Services, Informational only

Resolved
Major outage
Started about 1 month agoLasted about 2 hours
Updates
  • Resolved
    Resolved

    The StarLink outage has been resolved.

  • Identified
    Identified

    Starlink is currently experiencing a worldwide Internet outage

    This is not related to any ZoomCloud services. All ITCO services are operational.