Maxim Classic - Server Maintenance
Scheduled for 28/09/2025 at 4:00 AM – 5:00 AM
Affects
ITCO Maxim
Under maintenance from 4:00 AM to 5:00 AM
Maxim Classic
Under maintenance from 4:00 AM to 5:00 AM
Maxim Mobile
Under maintenance from 4:00 AM to 5:00 AM
Maxim Reports
Under maintenance from 4:00 AM to 5:00 AM
Completed
28/09/2025 at 5:00 AMCompleted
28/09/2025 at 5:00 AMMaintenance has completed successfully
In progress
28/09/2025 at 4:00 AMIn progress
28/09/2025 at 4:00 AMMaintenance is now in progress
Planned
28/09/2025 at 4:00 AMPlanned
28/09/2025 at 4:00 AMHello,
There will be a planned outage on Sunday afternoon for maintenance on all Maxim Classic Servers.
Date: Sunday, 28th September 2025
Outage Time: 5PM to 6PM
Duration: 1 hour
Databases Affected: All Maxim Classic
Services Affected: Maxim Classic Online
Maxim Reporting
Maxim Apps & Portals
We appreciate your patience and understanding while we carry out this essential maintenance.
Kind regards.
The Maxim Team