Maxim MX - Server Maintenance
Scheduled for 29/09/2025 at 5:30 AM – 6:30 AM
Affects
ITCO Maxim
Under maintenance from 5:30 AM to 6:30 AM
MaximMX
Under maintenance from 5:30 AM to 6:30 AM
Completed
29/09/2025 at 6:30 AMCompleted
29/09/2025 at 6:30 AMMaintenance has completed successfully
In progress
29/09/2025 at 5:30 AMIn progress
29/09/2025 at 5:30 AMMaintenance is now in progress
Planned
29/09/2025 at 5:30 AMPlanned
29/09/2025 at 5:30 AMHello,
There will be a planned outage on Monday, 29th September, for maintenance on all MX Servers.
Date: Monday, 29th September 2025
Outage Time: 6:30 PM to 7:30 pm (1 hour)
Databases Affected: Maxim MX
Services Affected: All Maxim MX Services
Thank you for your understanding.
Many thanks
Maxim Team