Maxim Classic Version Update 1.2.1.100
Scheduled for 16/11/2025 at 8:30 AM – 9:00 AM
Affects
ITCO Maxim
Under maintenance from 8:30 AM to 9:00 AM
Maxim Classic
Under maintenance from 8:30 AM to 9:00 AM
Maxim Mobile
Under maintenance from 8:30 AM to 9:00 AM
Maxim Reports
Under maintenance from 8:30 AM to 9:00 AM
Completed
16/11/2025 at 9:00 AMCompleted
16/11/2025 at 9:00 AMMaintenance has completed successfully
In progress
16/11/2025 at 8:30 AMIn progress
16/11/2025 at 8:30 AMMaintenance is now in progress
Planned
16/11/2025 at 8:30 AMPlanned
16/11/2025 at 8:30 AMHello All
There will be a planned outage this Sunday, 16th November for the release of Maxim Classic Version 1.2.1.100.
Date: Sunday, 16th November 2025
Outage Time: 21:30 PM to 22:00PM
Duration: 30 minutes
Databases Affected: Maxim Classic Customers
Services Affected: Maxim Classic Online, Maxim Reporting, Maxim Apps & Portals
Thank you
Maxim Development Team